<?xml version="1.0" encoding="UTF-8"?><rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:atom="http://www.w3.org/2005/Atom" version="2.0"><channel><title><![CDATA[🔴 Critical: Critical Unbound DNSSEC Validator Flaw Could Allow RCE via a Malicious DNS Zone]]></title><description><![CDATA[<p dir="auto">Every release of the <strong>Unbound</strong> DNS resolver prior to <strong>1.26.1</strong> contains a critical heap overflow vulnerability in its <strong>DNSSEC validator</strong>, according to an advisory published by maintainer <strong>NLnet Labs</strong>. The flaw can be triggered when an attacker who controls a malicious DNS zone sends queries to a vulnerable resolver, potentially allowing remote code execution.</p>
<p dir="auto">The vulnerability is tracked as <strong><a href="https://nvd.nist.gov/vuln/detail/CVE-2026-81642" target="_blank" rel="noopener noreferrer nofollow ugc">CVE-2026-81642</a></strong> and is addressed in <strong>Unbound 1.26.1</strong>, which was released on the same day as the advisory.</p>
<p dir="auto">Affected versions:</p>
<ul>
<li>All Unbound releases before <strong>1.26.1</strong></li>
</ul>
<p dir="auto">Mitigation:</p>
<ul>
<li>Upgrade to <strong>Unbound 1.26.1</strong> as soon as possible.</li>
</ul>
<p dir="auto">Source: <a href="https://thehackernews.com/2026/09/critical-unbound-dnssec-validator-flaw.html" target="_blank" rel="noopener noreferrer nofollow ugc">The Hacker News</a></p>
<p dir="auto">Has your organization already patched to Unbound 1.26.1, or are you still assessing exposure?</p>
]]></description><link>https://xploitlk.com/topic/372/critical-critical-unbound-dnssec-validator-flaw-could-allow-rce-via-a-malicious-dns-zone</link><generator>RSS for Node</generator><lastBuildDate>Tue, 27 Oct 2026 11:22:09 GMT</lastBuildDate><atom:link href="https://xploitlk.com/topic/372.rss" rel="self" type="application/rss+xml"/><pubDate>Fri, 18 Sep 2026 00:30:18 GMT</pubDate><ttl>60</ttl></channel></rss>